Dúvida na Aula 1.3

Página 2 de 2 Anterior  1, 2

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Re: Dúvida na Aula 1.3

Mensagem por Maurício Lamano Ferreira em Dom Jan 10, 2016 1:53 pm

[img][/img]

Maurício Lamano Ferreira

Mensagens : 39
Data de inscrição : 09/01/2016

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Dúvida na Aula 1.3

Mensagem por Maurício Lamano Ferreira em Dom Jan 10, 2016 1:54 pm

[img][/img]

Maurício Lamano Ferreira

Mensagens : 39
Data de inscrição : 09/01/2016

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Dúvida na Aula 1.3

Mensagem por Maurício Lamano Ferreira em Dom Jan 10, 2016 1:55 pm

[img][/img]

Maurício Lamano Ferreira

Mensagens : 39
Data de inscrição : 09/01/2016

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Dúvida na Aula 1.3

Mensagem por Maurício Lamano Ferreira em Dom Jan 10, 2016 1:56 pm

[img][/img]

Maurício Lamano Ferreira

Mensagens : 39
Data de inscrição : 09/01/2016

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Dúvida na Aula 1.3

Mensagem por Maurício Lamano Ferreira em Dom Jan 10, 2016 1:56 pm


Maurício Lamano Ferreira

Mensagens : 39
Data de inscrição : 09/01/2016

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Dúvida na Aula 1.3

Mensagem por Maurício Lamano Ferreira em Dom Jan 10, 2016 1:57 pm

Agradeço a sua extrema atenção!

Maurício Lamano Ferreira

Mensagens : 39
Data de inscrição : 09/01/2016

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Dúvida na Aula 1.3

Mensagem por Prof. Marcos em Dom Jan 10, 2016 2:28 pm

Maurício Lamano Ferreira escreveu:Foi isso que apareceu professor...
Eu tentei Documentos com letra maiúscula e minúscula...
Estou enviando os prints a seguir...


> setwd("Users/mauriciolamanoferreira/Documentos/R")
Error in setwd("Users/mauriciolamanoferreira/Documentos/R") :
 não é possível mudar o diretório de trabalho
> setwd("Users/mauriciolamanoferreira/documentos/R")
Error in setwd("Users/mauriciolamanoferreira/documentos/R") :
 não é possível mudar o diretório de trabalho
>

Opa, tem mais um erro pequeno no seu comando! Tem que ter uma barra no começo do endereço no MAC.

Você fez assim:
setwd("Users/mauriciolamanoferreira/Documentos/R")

E deveria estar assim:
setwd("/Users/mauriciolamanoferreira/Documentos/R")

Note a barra a mais no começo do endereço. Perceba que ela aparece quando você usar o getwd, mas ficou de fora aqui, e pode ser a fonte do erro.

Vou olhar os menus, mas tente novamente com a barra a mais antes, ok?
avatar
Prof. Marcos

Mensagens : 259
Data de inscrição : 23/12/2015
Idade : 36
Localização : Maceió, AL

Ver perfil do usuário https://cantinhodor.wordpress.com/

Voltar ao Topo Ir em baixo

Re: Dúvida na Aula 1.3

Mensagem por Prof. Marcos em Dom Jan 10, 2016 2:32 pm

Acho que agora vai, tente aí.

Mas olhando o menu, matei a charada: está no menu "Misc". Veja a primeira opção de Misc: "change working directory". Com esta opção você seleciona a pasta de trabalho manualmente (como no resultado do choose.dir pra quem usa windows), e depois o restante deve rodar.

Ufa!

Avise se deu certo, e tente as duas opções, pois é bom saber de cada caso, ok?
avatar
Prof. Marcos

Mensagens : 259
Data de inscrição : 23/12/2015
Idade : 36
Localização : Maceió, AL

Ver perfil do usuário https://cantinhodor.wordpress.com/

Voltar ao Topo Ir em baixo

Re: Dúvida na Aula 1.3

Mensagem por Maurício Lamano Ferreira em Dom Jan 10, 2016 3:03 pm

[img][/img]

Maurício Lamano Ferreira

Mensagens : 39
Data de inscrição : 09/01/2016

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Dúvida na Aula 1.3

Mensagem por Prof. Marcos em Dom Jan 10, 2016 3:06 pm

Puxa, mas que coisa...

Você conferiu o endereço da pasta no computador? Confira se os nomes das pastas estão corretas (Documentos, com o D maiúsculo, e o R também em letra maiúscula). De vez em quando uma pequena diferença passa desapercebida.

Como um teste, tente apenas:

setwd("/Users/mauriciolamanoferreira")

E veja se assim vai. Se form possivelmente há um erro em algum nome das pastas na sequência.

De qualquer forma, tente também via menu, no Misc, ok?

E vamos que vamos, daqui a pouco resolvemos.
avatar
Prof. Marcos

Mensagens : 259
Data de inscrição : 23/12/2015
Idade : 36
Localização : Maceió, AL

Ver perfil do usuário https://cantinhodor.wordpress.com/

Voltar ao Topo Ir em baixo

Re: Dúvida na Aula 1.3

Mensagem por Maurício Lamano Ferreira em Dom Jan 10, 2016 3:23 pm

boas notícias.... tentei o Misc e parece que deu certo...
Veja o anexo... porém, acho que o problema agora está na hora de conferir os dados... veja a figura!

Maurício Lamano Ferreira

Mensagens : 39
Data de inscrição : 09/01/2016

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Dúvida na Aula 1.3

Mensagem por Maurício Lamano Ferreira em Dom Jan 10, 2016 3:24 pm

[img][/img]

Maurício Lamano Ferreira

Mensagens : 39
Data de inscrição : 09/01/2016

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Dúvida na Aula 1.3

Mensagem por Prof. Marcos em Dom Jan 10, 2016 3:27 pm

Ufa, pelo menos deu certo a mudança de diretório. Que alívio!

Bom, para começar, teste a leitura de um arquivo bem simples:

https://dl.dropboxusercontent.com/u/12074355/teste.txt

E vamos ver se funciona com ele.
Se funcionar, então temos que descobrir qual o problema no seu arquivo.
avatar
Prof. Marcos

Mensagens : 259
Data de inscrição : 23/12/2015
Idade : 36
Localização : Maceió, AL

Ver perfil do usuário https://cantinhodor.wordpress.com/

Voltar ao Topo Ir em baixo

Re: Dúvida na Aula 1.3

Mensagem por Prof. Marcos em Dom Jan 10, 2016 3:29 pm

Ah, e faça uma coisa: depois de mudar o diretório pelo menu Misc, use o getwd().
Assim poderemos saber como deveria ser o endereço para o setwd, e você poderá usá-lo daqui para frente. Wink
avatar
Prof. Marcos

Mensagens : 259
Data de inscrição : 23/12/2015
Idade : 36
Localização : Maceió, AL

Ver perfil do usuário https://cantinhodor.wordpress.com/

Voltar ao Topo Ir em baixo

Re: Dúvida na Aula 1.3

Mensagem por Maurício Lamano Ferreira em Dom Jan 10, 2016 4:03 pm

Professor, este endereço me levou para uma página... não deu para pegá-lo como anexo!
Eu abri no notebook da minha esposa (sistema windows) o bloco de notas e salvei um arquivo muito simples.... em seguida o salvei no mac e o resultado deu certo! Agora vou fazer testes (tentativa e erro) para ver a melhor extensão (ou a que dê certo) seguindo as instruções que o senhor deu para a Giovanna sobre a extensão ".csv"....

setwd(Muitíssimo obrigado!) - rsrsrs




Maurício Lamano Ferreira

Mensagens : 39
Data de inscrição : 09/01/2016

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Dúvida na Aula 1.3

Mensagem por Maurício Lamano Ferreira em Dom Jan 10, 2016 4:04 pm

[img][/img]

Maurício Lamano Ferreira

Mensagens : 39
Data de inscrição : 09/01/2016

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Dúvida na Aula 1.3

Mensagem por Maurício Lamano Ferreira em Dom Jan 10, 2016 4:06 pm

Ah! Ao digitar getwd() apareceu o seguinte:

getwd()
[1] "/Users/mauriciolamanoferreira/Documents/R"

Maurício Lamano Ferreira

Mensagens : 39
Data de inscrição : 09/01/2016

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Dúvida na Aula 1.3

Mensagem por Prof. Marcos em Dom Jan 10, 2016 4:13 pm

Maurício Lamano Ferreira escreveu:Ah! Ao digitar getwd() apareceu o seguinte:

getwd()
[1] "/Users/mauriciolamanoferreira/Documents/R"

Bom, agora sabemos o que estava errado! Smile Era Documents, em inglês, e não Documentos.

Depois experimente usar o setwd("/Users/mauriciolamanoferreira/Documents/R"), que agora deve funcionar! Very Happy

Depois conversamos no outro tópico, então, pois esta questão dos arquivos é importante.

E vamos seguindo! cheers
avatar
Prof. Marcos

Mensagens : 259
Data de inscrição : 23/12/2015
Idade : 36
Localização : Maceió, AL

Ver perfil do usuário https://cantinhodor.wordpress.com/

Voltar ao Topo Ir em baixo

Re: Dúvida na Aula 1.3

Mensagem por Maurício Lamano Ferreira em Dom Jan 10, 2016 4:21 pm

Ok! Deu certo professor...
engraçado que no default está Documentos (em português)... mas que bom! Ficarei mais atento a estes detalhes[img][/img]

Maurício Lamano Ferreira

Mensagens : 39
Data de inscrição : 09/01/2016

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Dúvida na Aula 1.3

Mensagem por Maurício Lamano Ferreira em Dom Jan 10, 2016 4:23 pm

Bora continuar os estudos.... drunken

Maurício Lamano Ferreira

Mensagens : 39
Data de inscrição : 09/01/2016

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Dúvida na Aula 1.3

Mensagem por Maurício Lamano Ferreira em Dom Jan 10, 2016 4:23 pm

Obrigado...

Maurício Lamano Ferreira

Mensagens : 39
Data de inscrição : 09/01/2016

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Dúvida na Aula 1.3

Mensagem por Prof. Marcos em Dom Jan 10, 2016 4:51 pm

Maurício Lamano Ferreira escreveu:Obrigado...

Tranquilo!

Seguimos trabalhando, então. Smile
avatar
Prof. Marcos

Mensagens : 259
Data de inscrição : 23/12/2015
Idade : 36
Localização : Maceió, AL

Ver perfil do usuário https://cantinhodor.wordpress.com/

Voltar ao Topo Ir em baixo

Re: Dúvida na Aula 1.3

Mensagem por Maurício Lamano Ferreira em Ter Jan 12, 2016 12:30 am

Professor
Eu tive mais um problema, porém, após assistir a aula 1.6. consigo saber que se trata de um erro na qual eu devo apenas ajustar algum comando, pois o R está lendo o meu script, somente não está me dando o que quero...

Segue em anexo o problema... ao chamar o diretório e criar um objeto, se após o nome do meu arquivo eu colocar o header=T o R dá erro e se eu não colocar nada ele entende o objeto (inclusive já reconhece o nome da coluna, porém, acho que ele reconhece também uma linha acima da parte escrita da planilha (eu me refiro àquelas com os nomes das colunas: A, B, C...).

O que eu posso fazer para sair daqui?

abs[img][/img]

Maurício Lamano Ferreira

Mensagens : 39
Data de inscrição : 09/01/2016

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Dúvida na Aula 1.3

Mensagem por Prof. Marcos em Ter Jan 12, 2016 3:20 pm

Oi, Maurício!

Então, o problema são os acentos, e parece ser similar aos problemas que a Giovana está tendo.

Dê uma espiada na minha última resposta no tópico que ela criou, acho que a solução é a mesma. Lá ela está usando o read.csv, mas ele aceita os mesmos argumentos que read.table, ok? Então tente adicionar o argumento fileEncoding, como estou indicando lá.

Perceba que o header=T deve continuar, ok? Senão o R vai ler a primeira linha como se fossem dados, e não nomes.

Vamos que vamos!
avatar
Prof. Marcos

Mensagens : 259
Data de inscrição : 23/12/2015
Idade : 36
Localização : Maceió, AL

Ver perfil do usuário https://cantinhodor.wordpress.com/

Voltar ao Topo Ir em baixo

Re: Dúvida na Aula 1.3

Mensagem por Maurício Lamano Ferreira em Ter Jan 12, 2016 4:00 pm

obrigado professor... vou checar!
abs

Maurício Lamano Ferreira

Mensagens : 39
Data de inscrição : 09/01/2016

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Dúvida na Aula 1.3

Mensagem por Conteúdo patrocinado


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Página 2 de 2 Anterior  1, 2

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum